Value of mircoUSB Input Voltage in StromPI-Mode 3

258 views
0 Comments

Good morning,
I purchased 5 Strompi with Battery-Hat for a project that involves the use of Raspberry in different situations and I use the fw 1.7.
If I configure the Strompi in mode 4 with principal external power supply (12V) and Battery-Hat as secondary power supply, as show below in the setion Voltage-Levels, everything seems to work correctly.
If instead I use the mode 3 then the main MicroUSB power supply at 5V and Battery-Hat as secondary, using the Strompi3_status script the main voltage read on microUSB-InputVoltage is between 4.4 and 4.65V resulting in system instability. Furthermore the voltage referred to the Output Voltage is also significantly lower than 5V.
In mode 4 if the microUSB is also connected (which in any case would not be used by the system) the voltage read is 5.1V then value in accordance with the characteristics of the USB power supply used (12W 2,4A).
Why is the voltage noticeably lower than 5V if the main power supply is the MicroUSB?
I add that always in mode 3 at boot time, despite the Battery-HAT is always at 100% charge and I feed the raspberry with the microUSB, there is a cycle of at least 5 – 6 reboots that do not finish correctly and that can also corrupt the device. In mode 4 instead of the same hardware used, the booting happens correctly only once.
Why is this happening?
Thanks for your attention.
Best regards
———————————
StromPi-Status:
———————————
Time: 15:26:40
Date: Wednesday 29.05.19
StromPi-Output: mUSB
StromPi-Mode: mUSB -> Battery
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 70 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Enabled
Power Save Mode: Enabled
PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds
Battery-Level Shutdown: Disabled
Powerfail-Counter: 16

———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 3.612V [100%] [charging]
microUSB-Inputvoltage: 4.63V
Output-Voltage: 4.568V
———————————
StromPi-Status:
———————————
Time: 15:39:00
Date: Wednesday 29.05.19
StromPi-Output: Wide
StromPi-Mode: Wide -> Battery
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 70 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Enabled
Power Save Mode: Enabled
PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds
Battery-Level Shutdown: Disabled
Powerfail-Counter: 16

———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 11.767V
LifePo4-Batteryvoltage: 3.464V [100%] [charging]
microUSB-Inputvoltage: 5.116V
Output-Voltage: 5.042V

Answered question

Dear Flavio,
sorry for our late repla, as though a holiday here in Germany we were out of office.
This problem you are describing sounds strange, as like the powerpath of the mUSB is generating a resistance too high for correct specifications – to analyse this problem further I just wanted to ask to confirm:

  • This Problem appears on all of the 5 StromPi3?
  • Do you have tried an other mUSB Power Supply in this setup?
  • Which Power you are draining from the StromPi3 (only RPi or with additional peripherals)?

Best Regards,
Jarek

Answered question
Write your answer.