V 1.72 – Failed to init device

459 views
0 Comments

Hallo Support,
ich habe meinen StromPi auf 1.72 aktualisiert, den Mode auf „4“ eingestellt und den wake-up auf eine Minute um diesen zu testen. System per Konsole herunter gefahren, nach einer Minute wachte es auch wieder auf. Dann habe ich es nochmal probiert und nichts passierte mehr. Der StromPi liefert zwar wieder Versorgung für den Raspi aus dem Wide-Eingang, aber der Serialport des StromPi lässt sich nicht mehr ansprechen. Habe es mit einem frischen System versucht sowie einem anderen Raspi. Gleiches auch im „Flash“-Modus per Jumper.
Gibt es eine Möglichkeit den Port des StromPi zu resetten?
Ich habe den StromPi gemäß Anleitung „PowerOn-Button“ modifiziert, das klappte auch alles unter 1.7.
Hoffe ihr könnt mir hier helfen.
Gruß
StevieWW

Answered question

10 Answers

Guten Morgen StevieWW,
häufig liegt das Problem bei einer nicht funktionierenden seriellen Kommunikation darin, dass der Microcontroller nicht neugestartet wurde. Dieses liegt häufig an den Kondensatoren die auf dem StromPi verbaut sind. Der Microcontroller läuft auch noch mit Spannungen unter 2V und bis die Kondensatoren nur durch den Microcontroller soweit entladen sind dauert es eine ganze Zeit. Aus diesem Grund würde ich Ihnen empfehlen alle Stromversorgungen des StromPis auszuschalten und den Jumper „CAP“ einmal für ein paar Sekunden abzuziehen. Damit stellen Sie sicher, dass der Microcontroller stromlos ist und auf jeden Fall neustartet.
Falls der Neustart des Microcontrollers geholfen hat möchte ich Sie bitten den wake-up-alarm mit einer längeren Zeitspanne (z. B. 5 Minuten zu testen). Das würde uns beim Troubleshooting helfen.

Mit freundlichen Grüßen
Nils (Joy-IT)

Unselected an answer
Anonymous 0 Comments

Hallo Nils,
mittlerweile habe ich die Kommunikation RasPi – StromPi wieder verfügbar. Aber der StromPi weckt meinen RasPi nicht mehr auf. Ich hatte wie oben beschrieben mal die Zeit verlängert, zunächst auf 5 Minuten, dann auf 2 Minuten. Beides mal kein Wecken.
Witzigerweise klappt der PowerOn Button auch nicht mehr.
Ganz normal per Script „shutdown.py“ beendet.
Meine Konfig:
###########################################################################
StromPi V3 Serial Config Script (PYTHON3)
###########################################################################
—————————————————————————
Main Configuration
—————————————————————————
[StromPi-Mode: 6 (Wide -> mUSB -> Battery)]
Setting the StromPi mode
(1 = mUSB -> Wide, 2 = Wide -> mUSB, 3 = mUSB -> Battery, 4 = Wide -> Battery, 5 = mUSB -> Wide -> Battery, 6 = Wide -> mUSB -> Battery)
Mode (1-6): 4
————————————–
[Raspberry Pi Shutdown: Disabled]
Enabling or disabling the Raspberry Pi shutdown (0 = disable, 1 = enable)
Shutdown enable/disable (0 – 1): 0
————————————–
[Battery-Level Shutdown: Disabled]
Setting battery level shutdown (0 = disable, 1 = below 10%, 2 = below 25%, 3 = below 50%)
Battery level shutdown (0 – 3): 0
————————————–
[Serial-Less Mode: Disabled]
Enabling or disabling serialless-mode (0 = disable, 1 = enable)
Serialless mode (0 – 1): 0
————————————–
[Power Save Mode: Disabled]
Enabling or disabling the Power Save mode (0 = disable, 1 = enable)
Power Save mode (0 – 1): 0
————————————–
[Powerfail Warning: Disabled]
Enabling or disabling the Powerfail-Warning (instead of a shutdown) through the serial interface (0 = disable, 1 = enable)
Warning enable/disable (0 – 1): 0
————————————–
[PowerOn-Button: Enabled]
Enabling or disabling the PowerOn-Button Feature (0 = disable, 1 = enable)
PowerOn-Button enable/disable (0 – 1): 1
————————————–
[PowerOn-Button Initialization Time: 60 seconds]
PowerOn-Button Initialization Time: (seconds)
Seconds (0 – 65535): 30
—————————————————————————
Time&Date-Configuration
—————————————————————————
[Actual Raspberry Pi Time&Date]
[Time: 15:43:15]
[Date: Monday 19.08.19]
Do you want to change the Time&Date-Configuration? (Y) Yes | (N) No:N
—————————————————————————
Alarm-Configuration
—————————————————————————
[Actual Raspberry Pi Time&Date]
Alarm-Mode: Wakeup Timer
Alarm-Time: 00:00
Alarm-Date: 01.01
WakeUp-Alarm: Monday
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
Do you want to change the Alarm-Configuration? (Y) Yes | (N) No:Y
———————————————-
Power-Off Alarm Configuration
———————————————–
Do you want to change the Power-Off Alarm-Configuration? (Y) Yes | (N) No:N
—————————————————————————
Wake-Up Alarm-Configuration
—————————————————————————
Do you want to change the Wake-Up Alarm-Configuration? (Y) Yes | (N) No:Y
————————————–
Enabling or disabling wake up alarm (0 = disable, 1 = enable)
Wake up alarm status (0 – 1): 1
————————————–
Setting the wake up alarm mode (1 = Time-Alarm , 2 = Date-Alarm, 3 = Weekday-Alarm, 4 = Wakeup Timer)
Wake up alarm mode (1 – 4): 4
————————————–
Set the wake up Timer
Wake up Timer (1-65535): 2
————————————–
Setting the wake up alarm date (1 = Monday, 2 = Tuesday, 3 = Wednesday, 4 = Thursday, 5 = Friday, 6 = Saturday, 7 = Sunday)
Weekday (1 – 7): 1
———————————————-
Interval-Alarm Configuration
———————————————–
Do you want to change the Interval-Alarm-Configuration? (Y) Yes | (N) No:N
———————————————-
Configuration Successful
Transfer new Configuration to the StromPi 3
###Please Wait###
———————————————–
———————————————-
Transfer Successful
———————————————–
———————————
StromPi-Status:
———————————
Time: 15:45:09
Date: Monday 19.08.19
StromPi-Output: Wide
StromPi-Mode: Wide -> Battery
Raspberry Pi Shutdown: Disabled
Shutdown-Timer: 10 seconds
Powerfail Warning: Disabled
Serial-Less Mode: Disabled
Power Save Mode: Disabled
PowerOn-Button: Enabled
PowerOn-Button-Timer: 30 seconds
Poweroff Mode: Disabled
Battery-Level Shutdown: Disabled
Powerfail-Counter: 2
———————————
Alarm-Configuration:
———————————
WakeUp-Alarm: Enabled
Alarm-Mode: Wakeup Timer
Alarm-Time: 00:00
Alarm-Date: 01.01
WakeUp-Alarm: Monday
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 17.97V
LifePo4-Batteryvoltage: 3.461V [100%] [charging]
microUSB-Inputvoltage: not connected
Output-Voltage: 5.039V

Answered question

Guten Morgen StevieWW,
entschuldigen Sie bitte die Unannehmlichkeiten. Danke für die ausführliche Beschreibung des Problems. Wir werden versuchen den Fehler nachzustellen und zu untersuchen und melden uns schnellst möglich wieder hier.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question

Der PowerOn Button geht bei mir auch nicht so wie in der Anleitung beschrieben (siehe auch Posting „PowerOn-Button, welche Anleitung?“). Es dauert weit länger als die in der Beschreibung angegebenen 30 Sekunden bis man den Raspi wieder neu starten kann, mindestens 2-2,5min. warten, also ca. 30-60 Sekunden nachdem die rote LED ganz aus ist (dauert bei mir ca. 1,5min.), ist ein bischen schwer zu erkennen da die LED langsam aus dimmt. Anschließend den Reset überbrücken, bei zu kurze Überbrückung  z.B. mit einem Taster kann es auch vorkommen das der Raspi nicht startet, also lieber 1-2 Sek. drücken.

Answered question
StevieWW (anonymous) 0 Comments

Hallo Hansi,
da hast du mich auf ne Idee gebracht… Wenn du den Jumper „CAP“ auf off setzt, dann geht das besser mit dem PowerOnButton.
Trotzdem wacht mein Raspi nach der eingestellten Zeit nicht auf.

Answered question
Write your answer.