Umstieg von StromPi Rev1 auf Rev1.1 keine Funktion mehr gegeben

226 views
0 Comments

Hallo,
leider ist unser StromPi 3 der ersten Generation defekt und wir haben vor ein paar Tagen den Ersatz erhalten. Die Rev. 1.0 lief mit dem serialShutdown.py Script hervorragend und tat das was sie soll.
Nach dem umstecken der neuen Revision (1.1) wurde diese natürlich konfiguriert (über das CLI script stromPi3_config.py, welches allerdings ab und an eine Fehlermeldung ausspuckt: „..could not convert string to float…“)
Die Scripte wurden alle auf die neuste Version (1.72) von der Website aktualisiert.
ABER: Die vorherige Konfiguration funktioniert nicht mehr mit dem neuen StromPi. Der Shutdown wird nicht initiiert, der stromPi schaltet einfach nach der vorgegebenen Zeit ab und der Raspberry wird einfach stromlos geschaltet.
Das können wir so nicht lassen! Was muss an der Konfiguration geändert werden, damit ein sauberes Herunterfahren wieder möglich ist? Ansonsten ist der stromPi total unnötig in unserem Fall.

Danke
Gruß Newbow

Answered question

7 Answers

Guten Morgen Newbow,
da sich die Rev. 1.1 nur durch den serialless Jumper und die Vorbereitung für den PowerOn Button von der Rev. 1 unterscheidet, ist das Verhalten ungewöhnlich. Angesichts der heuten Deadline würde ich Sie bitten uns telefonisch unter 02845 93 60 50 zu kontaktieren und sich bitte zu mir (Nils Hoever) durchstellen zu lassen, um schnellst möglich eine Lösung zu erarbeiten.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Hannes (anonymous) 0 Comments

Bin bei meinem StromPi3 noch nicht vorgedrungen in serialless Bereiche weil ich das Ding noch nicht gelötet habe. Aber in diesem Zusammenhang die Frage:
Im neuen Firmwarepost der die Rev 1.1 vorstellt hier ist von einem neuen Jumper die Rede der für den serialless modus den PIN40 (GPIO21) verbindet.
Dazu meine logische Frage: ist der Jumper richtig gesetzt und ist der GPIO-PIN derselbe wie auf dem Rev 1.0 board gemodded wurde?? Sonst muss das irgendwo in der config eingestellt werden – vermutlich werdet Ihr daran schon gedacht haben…
Nachdem ich vor kurzem einen Tag vergeigt habe, einen Remotezugriffsverlust eines pi zero mit ethernet adapter zu suchen, der im Endeffekt ein Ethernetkabel ohne Klick hatte, das am Router leicht herausgerutscht war… die blödesten/simpelsten Fragen können manchmal die richtigen sein ^^
Viel Glück
Hannes

Answered question
Newbow (anonymous) 0 Comments

Hallo Zusammen,
Hat wirklich niemand eine Idee? Wir kommen hier echt nicht weiter und sind am verzweifeln.
Wir können gerade nicht riskieren eine Komplette neuinstallation durchzuführen nur um zu schauen, ob es hilft. Wir müssen wie gesagt unser Projekt morgen Mittag abgeben. Das alte setup mit Raspberry Pi 4 und dem StromPi 3 1.0 hat wunderbar funktioniert und wir brauchen die Funktionalität der USV um den Raspberry in der Anlage sauber herunterzufahren.

Vielen Dank
Gruß
Newbow

Answered question
Anonymous 0 Comments

ls -ls /dev/serial*

0 lrwxrwxrwx 1 root root 7 Jul 11 03:45 /dev/serial0 -> ttyAMA0
0 lrwxrwxrwx 1 root root 5 Jul 11 03:45 /dev/serial1 -> ttyS0

Answered question
Write your answer.