Tinker Board S mit Strompi 3

173 views
0 Comments

Hallo,
in den FAQ habe ich gelesen, dass man ein Tinker Board S auch mit einem StromPi 3 betreiben kann.
Ich versuche nun schon seit einigen Tagen am Tinker Board mit dem OS Armbian die serielle Schnittstelle einzustellen. Die Konfiguration wie „Interfacing Options“ oder „Serial“ kann ich in der Konfiguration nirgends finden. Eine Textdatei „ /boot/config.txt“ gibt es auch nicht.
python-serial python3-serial sowie minicom habe ich installiert.
Starte ich minicom, öffnet sich die Konfigurationskonsole.
Wähle ich einen Menüpunkt aus, wird minicom mit der Meldung „minicom: cannot open /dev/modem: No such file or directory“ beendet.
Was müsste ich wo konfigurieren um den StromPi am Tinker Board betreiben zu können
Gibt es vielleicht für das Tinker Board eine Anleitung wie für den Raspberry?
Vielen Dank.

Answered question

8 Answers

Guten Morgen Wulf,
das sind ja mal positive Nachrichten. Danke für die Rückmeldung und viel Spaß mit dem Strom Pi 3.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question

Hallo Nils,
vielen Dank für die Antwort. Mit Armbian habe ich es leider nicht hinbekommen. Nach langer Suche fand ich heraus, das beim TinkerOS die Schnittstellen wie beim Raspberry sind. Mit Minicom hatte ich das gleiche Erscheinungsbild wie unter Armbian. Dann habe ich es mit screen versucht. Funtionierte auf Anhieb. Auch das Firmwareupdate ist durchgelaufen.
Viele Grüße Wulf

Answered question

Guten Tag Wulf,
danke für den Screenshot. Als erstes brauchen Sie serial0 nicht mit ln durchlinken. Sie können mal testen, ob Sie mit „sudo minicom -D /dev/ttyS1 -b 38400“ weiterkommen. Es kann auch sein, dass ttyS1 nicht UART 1 ist, dass kann ich aber nicht mit Bestimmtheit sagen. Ansonsten können Sie mal mit z. B. einem Oszilloskop oder einem TTL-Kabel prüfen ob Pin 8 gerade überhaupt serielle Daten sendet.
Sollte das der Fall sein, dürfte einer Kommunikation mit dem StromPi nichts mehr im Wege stehen.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question

Hallo Nils,
nach einem Neustart kann ich wie auf dem Bild zu sehen, Minicom starten.


Alle gespeicherten Einstellungen sind noch vorhanden. Nun sollte ich eigentlich die Strompiconsole starten können.
Es passiert aber nichts.
Vielen Dank Wulf!

Answered question

Guten Tag Wulf,
ich habe leider noch immer kein Tinker Board hier vor Ort. Wenn Sie aber einen Screenshot von Minicom posten könnten, kann ich Ihnen evtl. noch Hinweise geben.

Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.