Stumbling with Strompi…

84 views
0 Comments

We are stumbling for 2 weeks now with the Strompi 3.
– The manual is very basic.
(For example there is a reset jumper at the Strompi (service department of Strompi asked us to do a reset but there is nowhere an explanation of this reset jumper).
– The manual changes in a month 2 times without any message 
(The download at ~1 November was the 8-10-2018 version, but suddenly there was a 15-10-2018 version at the site. (With the extra enable_uart=1 and core_freq=250 text at page 6)
– With mode 1. mUSB -> Wide:
Shutdown timer set to 60 seconds.
within a couple of seconds the Strompi shuts down the Raspberry!
Even with the power back detection (within 15 seconds mUSB power plugged in), the Strompi shuts down the Raspberry.
– With mode 3. mUSB -> Battery;
Shutdown timer set to 60 seconds.
Shutdown and power back detection was working well but the “Stromausfall” email won’t never work.
– We tried a couple of times/days.. to do a firmware update (to 1.2 or 1.4).
This was working well 1 time.
After that we spent hours and hours to do a firmware update again but always we got this message;
“Failed to init device”
Then we ordered a second Raspberry with another new Strompi and a fresh installled Raspian Image 
(Expensive solution fo a not working well Strompi…)
Even with this total new configuration we got different times this message “Failed to init device”. It won’t work.
Then we tried the first Strompi (it was not used for 3 days) and yes, with the exact same handling, the firmware flashes to 1.4, like magic!
Then we tried the second Strompi and yes, even this one would flash to 1.4!
(And yes, this is magic because we don’t know the solution..)
– But now we have another problem; 
With the 1.4 firmware, the console is very buggy:
Ones logged in, the second time it won’t work. Totally frozen screen in the terminal window.
(Or the second login gives a total mess on the screen with half commands of text)
(after editing some commands in the console and did 2 times show-status , the screen was frozen again).
We have sent different times an email to the service department of the Strompi but the feedback is very very basic and now we are waiting for more than 5 days for an answer.
So, the conclusion is; (with 30 years of IT experience, starting with the Apple II command line): this product could be a nice expansion for a Raspberry project, it could be perfect, but even with a hobby experiment this is not reliable and very frustrating (and not good for a good marriage….)
We shall send back the 2 Strompi’s + batteries to the distributor because we want a normal working product and not a beta version.

Answered question
Jarek (Joy-IT) (anonymous) 0 Comments

Hi John,
I’m sorry for the troubles you’ve experienced with the StromPi3 – our expansion is used on many different configurations and setups and there can be some problems created by such combinations which weren’t covered by our manuals.
But these issues, like you’re describing (shutdown without regarding the timer and the powerback function, the Shutdown Email Function error and the slow responding Terminal on Firmware v1.4)  are unfortunately new to me and didn’t came up by other customers and/or in our tests through the firmware development.
I’d like to help you directly (without the way through the service departement), so if possible you can mail me directly at j.ciszewski@joy-it.net – we can also give you support by telephone, so maybe you call our Hotline at +492845/936050 or you can leave your phone number at my email so I’ll call you back later.
Our EMail Response time can vary based on our service times (like weekends and so on)
Best Regards,
Jarek

Answered question
You are viewing 1 out of 1 answers, click here to view all answers.
Write your answer.