StromPi3 + RPI4 + Serial-Less Mode

223 views
0 Comments

I am struggling with the Serial less mode. I managed to activate it properly but have following issues:

  • Serial less mode is after each reboot deactivated. This means I can establish a connection via UART with the StromPI3. Is this on purpose or a bug? I need always to start script Start_Serialless.py. But this I want to avoid!
  • I connected Reset-Pin to two different GPIO pins (21 and 20). But both pins always have value HIGH; regardless if primary or secondary power source is used. I tried the provided script poweralarm_serialless.py and also reading the pin values with different tools.

I am using latest Raspbian Version and Firmware 1.72 for StromPI3. In serial mode power failure detection works fine.

Answered question

10 Answers

Hi Michael S.,
We are trying to reconstruct your observed behavior. Could you execute the StromPi status script and post the output over here?
Thank you.
Best regards
Nils (Joy-IT)

Answered question
Michael S. (anonymous) 0 Comments

Hi Nils,
attached the status script output. I disabled now „power save mode“ but this also didn’t solve the issue. I also tried GPIO4, because I found some discussion in internet that the RPI4 GPIO pins have no internal pullups and GPIO4 should still work in old behavior; whatever this exactly means. But anyway, GPIO4 also didn’t work.
Thanks a lot for your support & help,
Michael …
———————————
StromPi-Status:
———————————
Time: 00:02:32
Date: Tuesday 01.05.18
StromPi-Output: mUSB
StromPi-Mode: mUSB -> Wide
Raspberry Pi Shutdown: Disabled
Shutdown-Timer: 10 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Enabled
Power Save Mode: Disabled
PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds
Battery-Level Shutdown: Disabled
Powerfail-Counter: 0
PowerOff Mode: Disabled
———————————
Alarm-Configuration:
———————————
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01.01
WakeUp-Alarm: Monday
Weekend Wakeup: Enabled
Minute Wakeup Timer: 30 minutes
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 6.903V
LifePo4-Batteryvoltage:  not connected
microUSB-Inputvoltage: 5.054V
Output-Voltage: 5.015V

Answered question

Hi Michael,
we have tried to reconstruct the error with the GPIO tied on High, but on our Pi4 with GPIO21 the behaviour of the Pin turns out like excepted (High on normal state – Low on shutdown state). As i can see in your configuration, you have disabled the Shutdown function of the StromPi3 – so you want to check the current state of the StromPi3 for another purpose?
As for the Serial Communication turning on on reboot: Yes this behaviour is on purpose so the Raspberry Pi System Clock  can be synchronized with the RTC Clock of the StromPi3. We are providing Scripts which can be integrated into the Raspberry Pi Bootup procedure so it will sync the clock and then disable the serialinterface once again.
I have uploaded a modified (untested) Firmware where the serialinterface should stay off, also after a reboot. You can find it here for a test: https://strompi.joy-it.net/wp-content/uploads/2019/09/RB-StromPi3-SerialBootOff.zip
Best Regards,
Jarek

Answered question
Michael S. (anonymous) 0 Comments

Hi!
Before I change my config and play around, please let me know the behavior of the GPIO pin.
Currently I am using a StromPI2 and there I have following setup:

  • Powered by mUSB: GPIO pin high
  • Powered by Wide: GPIO pin low

The same setup I wanted to use with the StromPI3. You write now that the pin is on low when it’s in „shutdown state“. So what is the „shutdown state“? When is it reached? And when is the StromPI3 automatically switching off the RPi?
Thanks and KR,
Michael …

Answered question

Hi Michael,
when the StromPi3 has enabled the shutdown feature/Timer then it goes to the shutdown state is when a powerfailure on the main voltage source is detected – in this state the predefined shutdown-timer is counting down to give the Raspberry Pi time to quit its processes and shutdown the OS; after that the StromPi3 is cutting off the powersource from the Raspberry Pi and will it bring back after the main Power Source will be back online (this whole procedure would be the main UPS function of the SP3).
Here you can see how to enable the Shutdown-feature

In this described behaviour the Reset-Pin is High in the normal-state and Low in the „Timer“ and „shutted-down-state“. It would be possible to change the firmware to reconstruct the behaviour of the previous SP2, but for this we would need a more detailed description of your requirements.
Best Regards,
Jarek

Changed status to publish
Write your answer.