StromPI3 + PowerSaveMode Enabled + mUSB->Wide + Pi Shutdown

552 views
0 Comments

Hallo,
ich muss leider schon wieder ein Problem melden. Ich teste noch immer mein Setup und habe folgendes Problem. Ich will nachdem die Hauptversorgung via mUSB ausgefallen ist, auf Wide umgeschaltet wird, irgendwann später den Rpi + StromPI herunterfahren und warten bis wieder die Hauptversorgung via mUSB vorhanden ist.
Das klappt prinzipiell bei PowerSaveMode = Disabled ganz wunderbar. Alle LED’s am StromPI3 gehen aus bis mUSB wieder Spannung hat und er erweckt sogleich sich bzw. den RPI.
Aktiviere ich jedoch den PowerSaveMode (was ich brauche um den Akku zu schonen), dann springt die LED nach der Zeit des Shutdown Timers kurz auf rot (mUSB) und sogleich wieder auf blau (Wide). Nach der Zeit des Shutdown Timers beginnt das Spiel von vorne. Kehrt mUSB wieder zurück wird der RPI nicht aufgeweckt.
Irgendwas klappt da nicht. Warum? Ich dachte zuerst, das liegt an meiner modifizierten Firmware wo ich die Wide-Spannung auslese. Aber auch bei der Original-Firmware zeigt es das gleiche Verhalten.
Danke,
Michael …
Anbei meine Testconfig für Firmware v1.72:
———————————
StromPi-Status:
———————————
Time: 00:02:46
Date: Tuesday 01.05.18
StromPi-Output: mUSB
StromPi-Mode: mUSB -> Wide
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 30 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Disabled
Power Save Mode: Enabled
PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds
Battery-Level Shutdown: Disabled
Powerfail-Counter: 0
PowerOff Mode: Disabled
———————————
Alarm-Configuration:
———————————
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01.01
WakeUp-Alarm: Monday
Weekend Wakeup: Enabled
Minute Wakeup Timer: 30 minutes
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 7.418V
LifePo4-Batteryvoltage:  not connected
microUSB-Inputvoltage: 5.033V
Output-Voltage: 4.991V

Answered question

7 Answers

Michael S. (anonymous) 0 Comments

Hallo,
ich mache gerade einen Mehrtagestest wie stark sich die Akkuspannung an Wide, wenn der PowerSaveMode aktiviert ist, ändert. Deswegen kann ich aktuell die Firmware für den StromPI3 nicht ändern. Nachdem ich bei meinen eigenen Änderungen das Abschalten des Schaltreglers (L7987) in der Routine deaktiviert habe – was ihr ja nun ebenfalls macht – kann ich bestätigen, dass dies zum gewünschten Erfolg führt. Mit dem Nachteil, dass der Akku langsam weiter leer wird.
Ich melde mich wieder, wenn ich meine weiteren Test beendet habe!
lg/,

Answered question

Guten Morgen Michael S.,
Sie können sich eine Beta-Version der Firmware die den Fehler behebt hier herunterladen. Die geänderte main.c finden Sie hier.
Folgender Teil wurde geändert:

void Power_Off(void)
{
if (powersave_enable == 1 && (output_status!= 2 || charging == 1) )
{
HAL_GPIO_WritePin(CTRL_L7987_GPIO_Port, CTRL_L7987_Pin, GPIO_PIN_RESET);
}
output_status = 0;
charging = 0;
HAL_GPIO_WritePin(CTRL_VREG5_GPIO_Port, CTRL_VREG5_Pin, GPIO_PIN_RESET);
HAL_GPIO_WritePin(BOOST_EN_GPIO_Port, BOOST_EN_Pin, GPIO_PIN_SET);
HAL_GPIO_WritePin(CTRL_VUSB_GPIO_Port, CTRL_VUSB_Pin, GPIO_PIN_RESET);
}

Der PowerSaveMode verhält sich jetzt wie folgt:
Wird der StromPi über mUSB versorgt, ist der Schaltregler deaktiviert und es fließt ein Strom von < 20 μA. Fällt die Versorgung über mUSB aus und der Shutdown ist eingeschaltet, übernimmt die WIDE Versorgung. Jedoch muss nach dem Abschalten der Versorgung des Raspberry Pis der Mikrocontroller weiterhin versorgt werden. In diesem Fall fließt bei einer WIDE Versorgungsspannung von 7,5 V ein Strom < 15 mA (bei anderen Versorgungsspannung abweichend). Das heißt, dass ein(e) an WIDE angeschlossene(r) Batterie / Akku langsam entladen wird. Sollte ein Battery Hat verbaut sein, wird in diesem Fall bei aktiviertem PowerSaveMode der Microcontroller über den Battery Hat versorgt und der Schaltregler der WIDE Versorgung deaktiviert (auch im Mode 1).
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question

Guten Morgen Michael S.,
den Source Code gibt es dann natürlich auch :-).
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Michael S. (anonymous) 0 Comments

Super, wenn ihr das Problem nachstellen konntet. Bitte mir auch den Sourcecode zur Verfügung stellen, dass ich nach Test der Beta Version es auch mit meinen Anpassungen testen kann.
lg/m

Answered question

Guten Tag Michael S.,
wir haben einen Fehler in der Firmware gefunden, der den Fehler verursacht. Wir arbeiten gerade an der Behebung des Fehlers und werden in den nächsten Tagen eine Beta Version zum Testen veröffentlichen.

Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.