Strompi 3 – V1.72 – Serial Port always active after running Start_Serialless.py

247 views

Hello there,
Is there any reason why the Strompi 3 still answers on the serial port (minicom -s on /dev/serial0) after I enabled the „serialless“ mode using sspc/quit , and run „Start_Serialless.py“? This prevents me from using the „ultimate GPS HAT“ that uses the uart. Of course the GPS HAT is not placed during the following explanations:
I used GPIO_TPIN = 19 and soldered pin 20 on the reset pad, reset jumper still on (as described in the user manual),
and the „powershutdown_serialless.py“ script, also using the GPIO_TPIN = 19, works.
I start „Start_Serialless.py &“ followed by „powershutdown_serialless.py“ in /etc/rc.local as recommended in the user manual. I also run „Start_Serialless.py“ in the command line, but strompi is still active on serial port.
Strompi 3 freshly flashed with V1.72 with V1.72 scripts used.
Do you have hint what I could have done wrong?
Should I use a separate pin for „Start_Serialless.py“ than „powershutdown_serialless.py“?
Otherwise it’s a nice little PSU and I’m eager to have a look at the open code at some point!

Answered question

7 Answers

Anonymous 0 Comments

Dear Jordan, dear Nils,
It finally worked with GPIO 26 after I tried other pins. I think it’s because I have I2S enabled (although with GPIO 16 it did not worked either, I have no idea why). Anyway, most important, it works.
Thank you very much for your feedback! It kept my trying.
Best regards,
Elvis

Answered question
You are viewing 1 out of 7 answers, click here to view all answers.
Write your answer.