Strompi 3 – V1.72 – Serial Port always active after running Start_Serialless.py

971 views

Hello there,
Is there any reason why the Strompi 3 still answers on the serial port (minicom -s on /dev/serial0) after I enabled the „serialless“ mode using sspc/quit , and run „Start_Serialless.py“? This prevents me from using the „ultimate GPS HAT“ that uses the uart. Of course the GPS HAT is not placed during the following explanations:
I used GPIO_TPIN = 19 and soldered pin 20 on the reset pad, reset jumper still on (as described in the user manual),
and the „powershutdown_serialless.py“ script, also using the GPIO_TPIN = 19, works.
I start „Start_Serialless.py &“ followed by „powershutdown_serialless.py“ in /etc/rc.local as recommended in the user manual. I also run „Start_Serialless.py“ in the command line, but strompi is still active on serial port.
Strompi 3 freshly flashed with V1.72 with V1.72 scripts used.
Do you have hint what I could have done wrong?
Should I use a separate pin for „Start_Serialless.py“ than „powershutdown_serialless.py“?
Otherwise it’s a nice little PSU and I’m eager to have a look at the open code at some point!

Answered question

7 Answers

Hi Elvis,
Did you enable serialless via config script before you run the Start_Serialless script? This could be the reason why the StromPi still communicates via serial.

Best regards
Nils (Joy-IT)

Answered question
Anonymous 0 Comments

Dear Nils,
yes I did! 😊 and I „quit“ sspc…

Answered question
Anonymous 0 Comments

Is the gpio pin used in „Start_Serialless.py“ supposed to be the same as „powershutdown_serialless.py“ ?

Answered question

Good morning,
as you connect just one GPIO pin to the StromPi, this one pin need to be defined in every script.

Best regards
Nils (Joy-IT)

Answered question
Anonymous 0 Comments

Thanks Nils,
This I did. Any other hint? Can the „Auto“ jumper has an effect? Should I revert to a firmware older than V1.72?
Best regards,
Elvis

Answered question
Write your answer.