Spannungsanstieg beim Einschalten

152 views
0 Comments

Hallo,
der Strompi läuft bei mir einwandfrei mit einem PI4. Ein sehr spezielles Problem im Zusammenwirken mit USB-SATA-Adaptern konnte ich bislang nicht lösen. Beim Einschalten starten nämlich die SATA-Controller meistens nicht, was nach längerer Nachforschung darauf zurückzuführen ist, daß der Spannungsanstieg beim Einschalten zu flach ist, um die SATA-Controller sauber zu starten. Mit einem gepowerten USB-Hub dazwischen funktioniert es nämlich.
Irgendwelche Ideen, wie man das Problem lösen könnte?

Answered question

4 Answers

Stefan Pirnik (anonymous) 0 Comments

Hallo Nils,
zum Einen liegt es auf jeden Fall am Pufferkondensator, dass der Spannungsanstieg beim Einschalten für den SATA-Adapter zu flach ist. Ohne Kondensator gibt es keine Probleme. Da hätte ich für einen kommenden Release des Strompi den Vorschlag, einen Widerstand von ein paar Ohm zur Strombegrenzung beim Einschalten in Serie zum Kondensator zu spendieren. Es darf ja ruhig eine Sekunde dauern, bis der Kondensator geladen ist. Parallel dazu eine Schottkydiode, damit beim Entladen der volle Strom zur Verfügung steht.hat
Ein weiteres Problem hat dann noch zum sporadischen Ausfall der SATA-Adapter geführt, nämlich der Umstand, daß bei der Stromversorgung über den Wide-Eingang am Ausgang nur etwa 4,85V zur Verfügung stehen. Das mag lt. Spezifikation für den PI ausreichen, jedoch nicht für alle Peripheriegeräte. Nach der Umkonfigurierung auf mUSB -> Batt stehen die vollen 5,15V des Original-Netzteils zur Verfügung, womit ich jetzt 2 2,5″ Festplatten an den beiden USB3-Anschlüssen betreiben kann. Zum Abfangen von Stromspitzen (falls beide Platten gleichzeitig hochlaufen – 2x 700mA) habe ich ein 2. Netzteil direkt am PI dazugesteckt.
Wäre es hier nicht sinnvoll, die Ausgangsspannung des Schaltreglers für den Wide-Eingang entsprechend der Spannung des Original-Netzteiles auch auf ca. 5,15V zu erhöhen? Man könnte so auch vermeiden, daß die Spannung bei Powerfail am Wide nach Umschalten auf mUSB plötzlich um ca. 0.3V ansteigt – was nicht unbedingt stören muß, aber zumidest seltsam anmutet.

Answered question

Guten Tag Stefan P,
das könnte in der Tat die Ursache sein. Sie könnten den CAPS Jumper für einen Test auf OFF stecken (so sind die Kondensatoren nicht in den Versorgungsstromkreis eingebunden) und testen ob das Problem weiterhin besteht oder nicht. Sollten die USB-SATA Adapter funktionieren bestätigt dies Ihre Vermutung.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Stefan P (anonymous) 0 Comments

Hallo Nils,
danke für die rasche Antwort. Ich habe an jedem USB3-Port einen SATA-Adapter stecken und die Verbindung vom micro-USB am Strompi zu einem USB2 Port am Raspi gesteckt. Das mit dem Anstecken am high-power Port funktioniert so nicht, weil ich die USB3-Daten über den Micro-usb nicht rüberbringe. Ich habe jetzt hier leider kein Oszilloskop um genauer nachzusehen was passiert, aber mir ist in dem Zusammenhang der Pufferkondensator eingefallen. Eventuell verbraucht dessen Ladung so viel Strom, daß der Spannungsanstieg flach wird. In dem Fall würde eine Komination von Schottky-Diode mit parallelem Widerstand anstelle des Jumpers evtl. helfen – langsam laden über Widerstand, schnell entladen über Schottky-Diode. Letztendlich geht es ja nur darum, daß der Spannungsanstieg beim Einschalten steil genug ist, um den Reset des SATA-Controllers zu triggern (leider hat dieser auch keine externe Spannungsversorgung. Aber er funktioniert sonst gut und ich will jetzt nicht alle SATA-Adapter am Markt durchprobieren…).

Answered question

Guten Tag Stefan P,
betreiben Sie den USB-SATA Adapter an dem high power USB Anschluss des StromPi 3?
Falls nicht, würde ich Ihnen empfehlen, den USB-SATA Adapter für einen Test in den high power USB Port des StromPi 3 zu stecken. Zusätzlich muss natürlich eine Verbindung zwischen einem der USB Ports des Raspberry Pi und dem mUSB Port(Data in, Power out) des Strom Pi 3 mithilfe eines USB auf mUSB Kabels hergestellt werden. Sollte das funktionieren, können Sie die Kabelverbindung bestehen lassen und den Adapter noch mal an den USB Ports des Raspberry Pis testen.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.