Serielle Konsole antwortet nicht

447 views
0 Comments

Hallo zusammen,
heute habe ich meinen Strompi3 in Betrieb genommen mit einem neuen RasPi4:
uname -a
Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux
cat /etc/issue
Raspbian GNU/Linux 10 \n \l
sudo apt install python-serial python3-serial minicom python-dev python3-rpi.gpio
/boot/config.txt ergänzt:
dtoverlay=pi3-miniuart-bt
enable_uart=1
core_freq=250
sudo raspi-config
-> Interface Options -> Serial
Would you like a login shell to be accessible over serial? -> No
Would you like the serial port hardware to be enabled? -> Yes
reboot
sudo minicom -D /dev/serial0 -b 38400
Welcome to minicom 2.7.1
OPTIONS: I18n
Compiled on Aug 13 2017, 15:25:34.
Port /dev/serial0, 11:58:00
Press CTRL-A Z for help on special keys
Nach Eingabe von startstrompiconsole oder sspc passiert nichts.
stty -F /dev/serial0
speed 38400 baud; line = 0;
min = 1; time = 5;
ignbrk -brkint -icrnl -imaxbel
-opost -onlcr
-isig -icanon -iexten -echo -echoe -echok -echoctl -echoke

Was habe ich übersehen?
Danke und Gruß,
Franz

Answered question

6 Answers

Anonymous 0 Comments

Der nächste Nachtrag: Problem gelöst. Für einen Raspberry Pi 4 ist „dtoverlay=pi3-miniuart-bt“ in der config.txt wohl der falsche Parameter. Offenbar war uart durch Bluetooth belegt. Ich habe Bluetooth nun mit „dtoverlay=disable-bt“ deaktiviert, weil ich es nicht brauche. Wer es braucht, muss wahrscheinlich „dtoverlay=miniuart-bt“ verwenden.

Answered question
You are viewing 1 out of 6 answers, click here to view all answers.
Write your answer.