Serielle Konsole antwortet nicht

409 views
0 Comments

Hallo zusammen,
heute habe ich meinen Strompi3 in Betrieb genommen mit einem neuen RasPi4:
uname -a
Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux
cat /etc/issue
Raspbian GNU/Linux 10 \n \l
sudo apt install python-serial python3-serial minicom python-dev python3-rpi.gpio
/boot/config.txt ergänzt:
dtoverlay=pi3-miniuart-bt
enable_uart=1
core_freq=250
sudo raspi-config
-> Interface Options -> Serial
Would you like a login shell to be accessible over serial? -> No
Would you like the serial port hardware to be enabled? -> Yes
reboot
sudo minicom -D /dev/serial0 -b 38400
Welcome to minicom 2.7.1
OPTIONS: I18n
Compiled on Aug 13 2017, 15:25:34.
Port /dev/serial0, 11:58:00
Press CTRL-A Z for help on special keys
Nach Eingabe von startstrompiconsole oder sspc passiert nichts.
stty -F /dev/serial0
speed 38400 baud; line = 0;
min = 1; time = 5;
ignbrk -brkint -icrnl -imaxbel
-opost -onlcr
-isig -icanon -iexten -echo -echoe -echok -echoctl -echoke

Was habe ich übersehen?
Danke und Gruß,
Franz

Answered question

6 Answers

Hi Joe8,
thanks for the information. We know that undervoltage, in general, can affect the Raspberry Pi. But we didn’t now that a light undervoltage could cause problems with serial communication. Thank you again. We will investigate this.
Best regards
Nils (Joy-IT)

Answered question
Joe8 (anonymous) 0 Comments

I just wanted to give back something. I too could not get the Strompi console to work for the life of me on a new RPi4. Really…. it took me more than a day to troubleshoot.
Turns out is was caused by under voltage! There was a warning during bootup which showed up with dmesg but the system seemed to work fine and the led lighted up on the Strompi board so I gave it no more thought. But finally after using the wide power input with a proper power source everything worked. Maybe it’s already mentioned somewhere but otherwise I would include this in the manual quit prominently. Just for reference below my working configuration.
Assuming you already disabled the system console via raspi-config or editing /boot/cmdline.txt directly.

My changes to /boot/config.txt are:

# For Strompi3 attached to a RPi 4
dtoverlay=miniuart-bt
enable_uart=1
# for extra UART’s
dtoverlay=uart5

Now I can acces the Strompi console via /dev/serial0 which is a symbolic link to /dev/ttyAMA0.
Notes 

  • I’m using Raspbian/Debian 10.3 (Buster) and the firmware of the Strompi turned out to be V1.72.
  • On the RPI 4 it seems you can use „dtoverlay=miniuart-bt“ instead of „dtoverlay=pi3-miniuart-bt”. It’s availability can be checked with the command „dtoverlay -h miniuart-bt
  • You can also disable bluetooth completely with „dtoverlay=disable-bt” but this affects the automatic udev mapping of /dev/serial0
  • Omitting „core_freq=250” seems to work none withstanding the instructions output of „dtoverlay -h miniuart-bt“ although this conflicts with the information that „enable_uart=1“ also sets the core_freq to 250. I don’t use bluetooth but maybe one should also set this as per Joy-IT instructions.
  • On the RPi 4 you can also enable 4 other UART’s which use other pins and so making sure that there is never any interference with the Strompi serials connection. The extra UART which has the least overlap seems to be 5 so I added dtoverlay=uart5 in my setup.
  • Untested but I assume one could use a TTL usb cable to program the Strompi even without it being connected to a RPi, maybe a useful option for those using it in serial-less mode. Would even be better if we could use one of the microUSB port to acces UART. I tried that on the DATA in port but to no succes.
Answered question

Hi anonymous,
have you already tried, if the serial communication works with our prepared image from our download section?

Best regards
Nils (Joy-IT)

Answered question
Anonymous 0 Comments

I also have this problem (Strompi3 and RPi 4) cannot get serial to work!

Answered question
Anonymous 0 Comments

Der nächste Nachtrag: Problem gelöst. Für einen Raspberry Pi 4 ist „dtoverlay=pi3-miniuart-bt“ in der config.txt wohl der falsche Parameter. Offenbar war uart durch Bluetooth belegt. Ich habe Bluetooth nun mit „dtoverlay=disable-bt“ deaktiviert, weil ich es nicht brauche. Wer es braucht, muss wahrscheinlich „dtoverlay=miniuart-bt“ verwenden.

Answered question
Write your answer.