RPi4B + StromPi3 – Ethernet adapter losing IPv4 address

243 views
0 Comments

RPi4B running RaspiOS Buster Desktop „lite“
StromPi3 FW 1.72 (not flashed yet) + LiFePo Pack – nothing soldered yet – minicom & gui access working
I am randomly losing IPv4 Ethernet connection to my Pi which does not seem to happen when I remove the StromPi3. Disconnects happen after 30 Minutes to 2-3 days. This is happening on TWO RPi4Bs only when the StromPi3 is attached. Solution: reboot
Running on stock image from raspberry pi (Desktop w/o recommended software). Bluetooth disabled, WiFi disabled, Ethernet IP address configured statically (dhcpcd.conf) and only samba client and xrdp installed.
journalctl shows something (MAC address) claiming my ip-address. This does not happen when the StromPi3 is not attached.
Now I know this sounds strange to attribute to the StromPi3 but i have tested this on 2 RPi4Bs and they both behave the same way (same StromPi3 – I only own one). Right now my RPi4 has an uptime of almost 5 days without the StromPi3, never managed more than 2 days without losing connection. Anyone else experienced this?

Answered question

5 Answers

Hannes (anonymous) 0 Comments

It is working!!
Almost 4 days uptime and not a single drop of the ethernet connection from which it would have to recover and could potentially fail.
Solution: disabled „Energy Efficient Ethernet“ – add to /boot/config.txt:
dtparam=eee=off
I have no idea why this problem isn’t more widespread. I found this setting in a thread concerning an RPi3 with a very similar problem:
https://www.raspberrypi.org/forums/viewtopic.php?t=253398#p1546256
I didn’t have the same entries in my logs but that might be because I was using journalctl instead of syslog.
Even though most Pi users might use wifi, and of those using ethernet even fewer might use a static IP configuration like I do (all assumptions) but still the sheer amount of Pi’s out there should amount to more people experiencing this. Especially since I am using the raspi stock image and have installed almost nothing on top. Maybe a hardware issue – I will test that second pi4 again once I have it at my disposal. Maybe it was always only the one pi and I mixed them up at some point… i have an RPi3B+ with the same stock image of buster running with the same ethernet configuration and it has never shown this behaviour.
Very esoterical at this point ^^
Thanks for the advice and „seelischen Beistand“ Nils!
Hannes

Answered question
Hannes (anonymous) 0 Comments

Connected my Pi4 (with StromPi3) to a different router with a different ethernet cable and after 4 days it lost its IPv4 again =(
Since I am now gaining more log data it has become obvious that the ethernet on the pi seems to drop and then reconnects, sometimes successfully. The dhcpcd service often times seems to crash during that reconnection process. The drops are random and I have seen drops occurring within hours of each other, sometimes more than a day in between.
Solution being tested at the moment (looks promising):
I disabled the „energy efficient ethernet“ function of the pi:
/boot/config.txt
add: „dtparam=eee=off“
I haven’t had a single drop in over 12 hours (which according to my log experience is too soon to say for sure) but I am fairly confident I found the culprit. Will post in a couple of days…
Hannes

Answered question

Hi Hannes,
it’s good that you can narrow the error down a little bit now. However, this is a very unpleasant problem if it takes several days to know if you have solved it. In any case, I wish you good luck in solving the problem.
Best regards
Nils (Joy-IT)

Answered question
Hannes (anonymous) 0 Comments

Hi Nils!
Thanks for the answer/advice!
My RPi4B lost its IPv4 address just now –  after an uptime of almost a week – this time without the StromPi3!!
I had researched a lot about this beforehand and have a few things I want to test since I now know it is not the StromPi3. (disable avahi daemon for instance)
Your answer makes me question my router, something I had not thought about before – I had checked all DHCP related things on my domainserver to rule out handing the IP address of my pi to some other device but there could of course be a problem with Ethernet and the router/switch – thanks for that idea!! Especially since there are two Pis suffering the same problem. If all the RPis had this problem I am sure I would have found a lot more people with it. Windows machines running on this switch didn’t have similar problems though.
The StromPi is obviously not the problem but I will update this if I manage to find a solution/the culprit.
On a sidenote:
I found out a few days ago that there is the rev 1.1 with the reset and serialless mods already built in – something I haven’t managed to do myself yet, since I lack experience and the tools to solder something THAT small – I hope to be able to test all the StromPi features as soon as I get it soldered and can reset it without taking the case and the battery apart – troubleshooting this random problem kept me from experimenting with the StromPi.
Many thanks!
Hannes

Answered question

Hi Hannes,
such a problem has never occurred before. We have also not received any support requests from our customers in this regard.
One possibility for this problem could be a ground loop.
Variant 1:
The router/switch is operated via the same DC source as the StromPi 3, in which case a ground loop could affect the signal.
Possible solution:
Use 2 separate power supplies for the StromPi 3 and the router/switch and test if the problem still exists.
Variant 2:
Both the StromPi 3 and the router/switch are operated with power supply units that have a plug with a connection to the mains earth. In this case, this loop can cause interference.
Possible solution:
Try to operate at least one device, but better both devices, with power supply units without a connection to mains earth. Sometimes it may be sufficient to insert the plug the other way around into the socket or to operate the devices not with a power socket strip but with two different wall sockets.

Best regards
Nils (Joy-IT)

Answered question
Write your answer.