RPi4 + Strompi3: Shutdown funktioniert nicht korrekt, Strompi schaltet zu früh ab.

1.12K views
0 Comments

So langsam bin ich genervt. Ich überlege langsam ernsthaft die USV zu wechseln.
Ich habe soeben herausgefunden das der strompi3 beim shutdown zu früh den strom abschaltet. In der /var/log/syslog brechen die Meldungen ab direkt nachdem das serialShutdown Script „sudo shutdown -h now“ ausführt. Danach in der syslog korrupte Daten: @@@@@@@@@@@@@@@@@@….. Ausserdem sehe ich nach einem Neustart in der syslog die Meldung das ein dirty bit geseztt wurde, also die Dateisysteme nicht korrekt unmounted wurden und evtl Daten korrupt sind. Die LEDs gehen nach dem shutdown sehr schnell aus, obwohl ich für den shutdown-timer eine Zeit von 300s konfiguriert habe.
Wenn ich manuell shutdown -h now in der Konsole ausführe sehe ich sauber die Meldungen bis der rpi komplett heruntergefahren wird.
Will ich den Status des Strompi abfragen bekomme ich nur Fehlermeldungen, da natürlich im Hintergrund das shutdown-Skript läuft und ein gleichzeitiger Zugriff nicht möglich ist (wieso programmiert man so eine Lösung?). Nachdem dann endlich das shutdown-script abgestürzt ist kann ich auch den Status auslesen.

Wo liegt der Fehler?

———————————
StromPi-Status:
———————————
Time: 04:22:21
Date: Saturday 19.05.18
StromPi-Output: Wide
StromPi-Mode: Wide -> Battery
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 300 seconds
Powerfail Warning: Disabled
Serial-Less Mode: Disabled
Power Save Mode: Disabled
PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds
Battery-Level Shutdown: 25%
Powerfail-Counter: 35
PowerOff Mode: Disabled
———————————
Alarm-Configuration:
———————————
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01.01
WakeUp-Alarm: Monday
Weekend Wakeup: Enabled
Minute Wakeup Timer: 30 minutes
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 13.889V
LifePo4-Batteryvoltage: 3.49V [100%] [charging]
microUSB-Inputvoltage: not connected
Output-Voltage: 5.024V

Answered question

19 Answers

Max (anonymous) 0 Comments

Danke!
J.K.

Answered question

Guten Tag Max,
ich schaue wo es hängt und melde per Mail.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Max (anonymous) 0 Comments

Hallo Nils,
am 12.3. habe ich per Mail die Ankündigung bekommen, dass am Folgetag ein Ersatzgerät versandt werden soll. Seitdem habe ich trotz Nachfrage am 16.3. keine Statusmeldung erhalten.
Hier im Forum habe ich gesehen das weiterhin Aktivität in diesem Thema herrscht.
Ich bitte um Statusmeldung per Mail und Versandbestätigung.
Max (J.K.)

Answered question
Franz (anonymous) 0 Comments

Hallo Nils,
ich habe inzwischen RB-StromPi3_v172_timermod aufgespielt. Seitdem geht die gelbe LED am Battery-HAT immer nur kurz aus (ca. 3 sec.), anschließend wieder an (ca. 15 sec.). Per minicom (es ist gar nicht nötig, sich in die strompiconsole einzuloggen, es reicht ja der Zugriff auf die serielle Schnittstelle) sehe ich:
xxx–StromPiPowerBack–xxx
xxxShutdownRaspberryPixxx
xxx–StromPiPowerBack–xxx
xxxShutdownRaspberryPixxx
xxx–StromPiPowerBack–xxx
xxxShutdownRaspberryPixxx
xxx–StromPiPowerBack–xxx
xxxShutdownRaspberryPixxx
xxx–StromPiPowerBack–xxx

Ist die Firmware fehlerhaft?
Ich bin derweil wieder auf 1.72 zurückgegangen. Ja, die Meldungen kommen auf der seriellen Schnittstelle an. Abweichend von den genannten Parametern habe ich beim Strompi per Config-Script den Shutdown-Timer auf 180 Sekunden eingestellt. Das Script poweralarm_serial.py sendet auch die erwarteten Mails.
Im Script serialShutdown.py habe ich 120 Sekunden eingestellt. In dieser Konstellation funktioniert der Strompi wie erwartet: Nach 120 Sekunden wird der Pi heruntergefahren, nach 180 Sekunden schaltet auch der Strompi ab.
Soweit kann ich damit erst mal arbeiten. Eine korrigierte (und offizielle) Firmware wäre wünschenswert.
Viele Grüße,
Franz

Answered question

Guten Tag Franz,
haben Sie mal mit Hilfe von „minicom“ getestet ob über die serielle Schnittstelle die Keywords ausgegeben werden?

  1. Starten Sie minicom
  2. Starten Sie die Console mit „startstrompiconsole“ oder „sspc“
  3. Trennen Sie die primäre Stromversorgung. Es sollte „xxxShutdownRaspberryPixxx“ angezeigt werden.
  4. Stellen Sie die primäre Stromversorgung wieder her. Es sollte „xxx–StromPiPowerBack–xxx“ angezeigt werden.

Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.