RPi 4B+ && StromPi v3 && Battery Hat | Under-voltage detected

481 views

Hey,
obwohl ich den StromPi v3 mit dem originalen Netzteil mit Strom versorge erhalte ich auf der Konsole die Warnung dass zu wenig Strom geliefert wird.

pi@raspberrypi:~ $ grep -i voltage -A1 -B1 /var/log/syslog && tail -F /var/log/syslog | grep -i voltage -A1 -B1
Jan 27 12:39:44 raspberrypi kernel: [ 4.647204] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
Jan 27 12:39:44 raspberrypi kernel: [ 5.911799] Under-voltage detected! (0x00050005)
Jan 27 12:39:44 raspberrypi kernel: [ 6.481281] random: crng init done

Jan 27 12:39:51 raspberrypi dhcpcd[371]: eth0: probing address 192.168.188.23/24
Jan 27 12:39:51 raspberrypi kernel: [ 14.231840] Voltage normalised (0x00000000)
Jan 27 12:39:55 raspberrypi systemd[1]: systemd-rfkill.service: Succeeded.

Jan 27 13:18:35 raspberrypi kernel: [ 5.091886] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
Jan 27 13:18:35 raspberrypi kernel: [ 6.071783] Under-voltage detected! (0x00050005)
Jan 27 13:18:35 raspberrypi kernel: [ 6.619356] random: crng init done

Jan 27 13:18:42 raspberrypi dhcpcd[377]: eth0: soliciting an IPv6 router
Jan 27 13:18:42 raspberrypi kernel: [ 14.391748] Voltage normalised (0x00000000)
Jan 27 13:18:43 raspberrypi dhcpcd[377]: eth0: rebinding lease of 192.168.188.23

Jan 27 13:23:01 raspberrypi kernel: [ 4.681716] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
Jan 27 13:23:01 raspberrypi kernel: [ 5.911911] Under-voltage detected! (0x00050005)
Jan 27 13:23:01 raspberrypi systemd[1]: Started Daily rotation of log files.

Jan 27 13:23:08 raspberrypi systemd[1]: Started Hostname Service.
Jan 27 13:23:08 raspberrypi kernel: [ 14.231740] Voltage normalised (0x00000000)
Jan 27 13:23:09 raspberrypi dhcpcd[378]: eth0: rebinding lease of 192.168.188.23

Wie könnte ich in diesem Setup Strom sparen bzw. ist eine doppel-Versorgung mit zwei Netzteilen notwendig?
> https://www.amazon.de/Raspberry-Pi-offizielles-Netzteil-Model/dp/B07TMPC9FG
> https://www.amazon.de/CHOETECH-Adapter-Micro-USB-Unterst%C3%BCtzt-Charging-schwarz/dp/B07145W7WX

Ihre CLI zeigt dieses an. Ja, der StromPi wird erstmals betrieben und geladen und zieht deshalb noch Strom für die Batterie.

adc-output
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 3.271 V [50%] [charging]
microUSB-Inputvoltage: 5.042 V
Output-Voltage: 4.962 V
****************************

Laut Aussage vor Kauf wird das Setup genügen Strom liefern um eine weiteren HAT nutzen zu können….
Das kann ich nun nach Kauf leider derzeit nicht bestätigen 🙁

Es grüßt,
Olli

Answered question

9 Answers

Patrick (anonymous) 0 Comments

Ich habe leider diese Beobachtung auch schon gemacht: Mit dem Original-Raspberry-3-Netzteil ist die Spannung einfach sehr knapp. Es funktioniert gerade so, aber die CPU geht in den Sparmodus (erkennbar am roten Balken in der CPU-Temperaturanzeige oben rechts) und auf dem Display erscheint permanent ein Blitz-Symbol. Auch ein anderes Netzteil (von einem Mobiltelefon) liefert das selbe Ergebnis. Das Original-Raspberry-Pi-4 Netzteil funktioniert leider nicht, weil der Stecker nicht zum StromPi-Eingang passt. Wenn ich eine Spannungsquelle über den Wide-Eingang anschliesse, sind die Symptome weg. Und natürlich auch, wenn ich gleichzeitig das Pi-4-Netzteil am Pi selbst einstecke, aber das ist natürlich nicht sinnvoll, weil dann die ganzen Power-On-Off-Funktionen nicht mehr funktionieren.

Answered question

Guten Morgen Olli,
ich habe gerade in Ihrem 2. Beitrag gesehen, dass Sie jetzt noch einen 2. funktionierenden StromPi 3 besitzen. Ist das verhalten mit diesem StromPi 3 identisch?
Können Sie bitte einmal „cat /proc/cpuinfo“ ausführen und die Ausgabe hier posten.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Anonymous 0 Comments

Guten Abend Nils,
meine Beobachtung sind dass der RPi 4B+ auch mit folgenden Netzteilen nicht die geforderte Versorgung via dem StromPi v3 erhält (laut Log-Daten).
> https://www.amazon.de/UrbanX-Quick-Charge-3-0-USB-Wandladeger%C3%A4t-Schwarz/dp/B07GDSFJX7/ (Mit EU Stecker)
>> Ausgang: DC 5V/3A, 9V/2A, 12V/1.5A

Über eine Empfehlung (privat) würde ich mich sehr freuen. Mein kleines Projekt würd ich gern fertig stellen 😉
Auch eine Empfehlung bzgl. Kabel nehme ich gern entgegen.

Es dankt,
Olli

Answered question

Guten Tag Olli,
das der Akku geladen wird ist absolut unkritisch, da dieser nur mit einem Ladestrom von 200 mA geladen wird. Das die Undervoltage Warnung so früh (Spannung > 4,9V) kommt, ist auch ungewöhnlich. Allerdings ist die gemessene Spannung von 5,042V auch etw. niedrig für ein originales Netzteil. Verwenden Sie ein Raspberry Pi 4 USB-C Netzteil in Verbindung mit einem Adapter auf mUSB? Sollte dieses der Fall sein, könnte der Adapter diese Auffälligkeiten verursachen. Besteht die Möglichkeit, dass Sie ihr Setup mit einem mUSB Netzteil ohne Adapter betreiben (es kann sich auch um ein USB Ladegerät handeln, welches maximal 2,4 A liefern kann).
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.