RPi 4B+ && StromPi v3 && Battery Hat | Under-voltage detected

1.75K views

Hey,
obwohl ich den StromPi v3 mit dem originalen Netzteil mit Strom versorge erhalte ich auf der Konsole die Warnung dass zu wenig Strom geliefert wird.

pi@raspberrypi:~ $ grep -i voltage -A1 -B1 /var/log/syslog && tail -F /var/log/syslog | grep -i voltage -A1 -B1
Jan 27 12:39:44 raspberrypi kernel: [ 4.647204] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
Jan 27 12:39:44 raspberrypi kernel: [ 5.911799] Under-voltage detected! (0x00050005)
Jan 27 12:39:44 raspberrypi kernel: [ 6.481281] random: crng init done

Jan 27 12:39:51 raspberrypi dhcpcd[371]: eth0: probing address 192.168.188.23/24
Jan 27 12:39:51 raspberrypi kernel: [ 14.231840] Voltage normalised (0x00000000)
Jan 27 12:39:55 raspberrypi systemd[1]: systemd-rfkill.service: Succeeded.

Jan 27 13:18:35 raspberrypi kernel: [ 5.091886] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
Jan 27 13:18:35 raspberrypi kernel: [ 6.071783] Under-voltage detected! (0x00050005)
Jan 27 13:18:35 raspberrypi kernel: [ 6.619356] random: crng init done

Jan 27 13:18:42 raspberrypi dhcpcd[377]: eth0: soliciting an IPv6 router
Jan 27 13:18:42 raspberrypi kernel: [ 14.391748] Voltage normalised (0x00000000)
Jan 27 13:18:43 raspberrypi dhcpcd[377]: eth0: rebinding lease of 192.168.188.23

Jan 27 13:23:01 raspberrypi kernel: [ 4.681716] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
Jan 27 13:23:01 raspberrypi kernel: [ 5.911911] Under-voltage detected! (0x00050005)
Jan 27 13:23:01 raspberrypi systemd[1]: Started Daily rotation of log files.

Jan 27 13:23:08 raspberrypi systemd[1]: Started Hostname Service.
Jan 27 13:23:08 raspberrypi kernel: [ 14.231740] Voltage normalised (0x00000000)
Jan 27 13:23:09 raspberrypi dhcpcd[378]: eth0: rebinding lease of 192.168.188.23

Wie könnte ich in diesem Setup Strom sparen bzw. ist eine doppel-Versorgung mit zwei Netzteilen notwendig?
> https://www.amazon.de/Raspberry-Pi-offizielles-Netzteil-Model/dp/B07TMPC9FG
> https://www.amazon.de/CHOETECH-Adapter-Micro-USB-Unterst%C3%BCtzt-Charging-schwarz/dp/B07145W7WX

Ihre CLI zeigt dieses an. Ja, der StromPi wird erstmals betrieben und geladen und zieht deshalb noch Strom für die Batterie.

adc-output
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 3.271 V [50%] [charging]
microUSB-Inputvoltage: 5.042 V
Output-Voltage: 4.962 V
****************************

Laut Aussage vor Kauf wird das Setup genügen Strom liefern um eine weiteren HAT nutzen zu können….
Das kann ich nun nach Kauf leider derzeit nicht bestätigen 🙁

Es grüßt,
Olli

Answered question

11 Answers

Also auf dem USB-Netzteil steht zumindest drauf, dass es 3A liefert. Ob das auch stimmt, kann ich allerdings nicht überprüfen (d.h. ich wüsste nicht wie, der Stecker ist zu klein, um daran was zu messen). Gemäss der Anzeige des Netzteils, das ich für den Wide-Eingang verwende, braucht mein Aufbau (mit Bildschirm) etwa 0.8A bei 10V. Das entspricht 1.6A bei 5V, was deutlich innerhalb der Spezifikation sein sollte(!). Ich melde mich, sobald möglich (bin aber gerade während der Bürozeiten ziemlich belegt).

Answered question
You are viewing 1 out of 11 answers, click here to view all answers.
Write your answer.