Resolution of Alarm-Time and PowerOff-Alarm-Time only in minutes?

536 views
0 Comments

Hi.
I’m currently working with firmware version 1.7 using strompi-mode 3.
It is my goal to ensure that after loss of the primary power source the Raspberry Pi shuts down and the StromPi as well a short time after that. I fear that if there happens a PowerBack event after the RaspberryPi has begun to shutdown the StromPi does not. In this situation the re-attching of the primary power source does not boot the RasperryPi.
I assume that setting a PowerOff-Alarm-Time in the near future would ensure the powering off of the StromPi. BUT I can see that the PowerOff-Alarm-Time does not take seconds? Is that an error in the documentation? Why would it not be possbile to set a PowerOff-Alarm-Time with a resolution of 1 second?
Overall, is my way of tackling the problem stringent? As the documentation was rather rudimentary this has been my approach so far.
Regards, Armin

Answered question

21 Answers

Armin (anonymous) 0 Comments

Hi Jarek,
great, thank you, I was now able to verify my scripted configuration of StromPi including my custom configs.
Thank you very much.
Best regards, Armin

Answered question

Hi Armin,
the Poweroff-feature linked to set-config 25 is included in the current configuration scripts, so also there the status would be shown. Unfortunately the timer wouldn’t be included in the scripts as for now, but I have uploaded here https://strompi.joy-it.net/wp-content/uploads/2019/06/RB-StromPi3-Armin2.zip a version with the possibility to go into the terminal and use the „show-status“ command to look into the configured values.
Best Regards,
Jarek

Answered question
Armin (anonymous) 0 Comments

Hi Jarek, thanks for your answer.
Till now the described behaviour did not occur again. I will keep you posted.
One more question: Is there a way to get the current configuration of the StromPi including my special values that are being set with ids 25 and 26 with command set-config? Is there a get-config?
Best regards, Armin

Answered question

Hi Armin,
I have just rechecked the Firmware and couldn’t reproduce your prpblems – can you try your procedure with the settings described in the picture which I have attached at this message. Also please make sure that the battery would be charged above 50%.
Best Regards,
Jarek

Answered question
Armin (anonymous) 0 Comments

Hi Jarek,
I’ve given the process described by me another try with a (minor?) difference:
Previously I have used this sequence to configure the custom items:
set-config 25 1
set-config 26 11
set-config 0 0
This led to the described loop.
Now I have altered the sequence a little and the behaviour seems to be ok now:
set-config 25 1
set-config 0 0
set-config 26 15
set-config 0 0
2 differences:

  1. set-config 0 0 is executed after each custom setting command, does this have an effect compared to execute it once after both commands?
  2. The 26-Timer has been set to 15, was 11 before. Is 11 too narrow to the 10 seconds of the power-off timer? Would make no sense to me if it were.

Best regards, Armin

Answered question
Write your answer.