RB 4 + StromPi 3 + Batterie Hat + Moitessier HAT (rooco)

211 views
0 Comments

Hallo, ich komme leider trotz eines langen Sonntages nicht weiter. Kurz zu meinem System. Ich möchte auf einem Raspberry Pi4 mit dem Strompi3 und Batterie HAT eine USV realisieren. Diese soll nur bei einem zu geringen Akku stand den Pi herunterfahren (Battery Shutdown Mode). Später soll auch ein Moitessier HAT (Rooco) GPS Sensordaten liefern.

Aber nun erstmal nach der Reihe…Ich habe auf dem PI Raspian mit der Openplotter vorkonfiguration installiert. Montiert sind der Strom Pi und Batterie HAT. Wenn ich jetzt wie in Kapitel 5 der Anleitung beschrieben

sudo apt-get install python-serial python3-serial

ausführe schlägt die Installation jedes mal fehl.
Edit###
Hallo Tim, na klar. Hier ist die Fehlermeldung:

pi@openplotter:~ $ sudo apt-get install python-serial python3-serial
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen…. Fertig
python-serial ist schon die neueste Version (3.4-4).
python3-serial ist schon die neueste Version (3.4-4).
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benöti gt:
libmicrodns0 rpi-eeprom-images
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 10 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] J
moitessier (2.1.0) wird eingerichtet …

******************************************************************************** **********
Running post install…
******************************************************************************** **********

/etc/systemd/system/moitessier.shutdown.service

******************************************************************************** **********
File /etc/systemd/system/moitessier.shutdown.service deleted.
******************************************************************************** **********

[Unit]
Description=Moitessier Shutdown

[Service]
ExecStart=/home/pi/moitessier/scripts/system_shutdown
Restart=always

[Install]
WantedBy=multi-user.target

******************************************************************************** **********
Setting up interfaces…
******************************************************************************** **********

moitessier: setting up /etc/modules
i2c-dev

******************************************************************************** **********
Updating HAT firmware…
******************************************************************************** **********

******************************************************************************** **********
This script is used to flash the STM32 microcontroller on the Moitessier HAT.

One of the following options can be applied:
-r : Will load the latest firmware release from the remote repository https: //github.com/mr-rooney/moitessier-firmware.git.
The firmware will be located in „./fw/application.binary“.
-s : Specifies the firmware that should be used.
This option requires the path + filename as parameter
-f : Forces the Raspberry Pi to shutdown after firmware update. A shutdown + power cycle
is required only for virgin Moitessier HATs without any firmware.

Note: Options -s and -r must not be applied at the same time!!
******************************************************************************** **********

******************************************************************************** **********
Determining I2C GPIO device
******************************************************************************** **********

******************************************************************************** **********
I2C GPIO device (probing failed, using default): i2c-3
******************************************************************************** **********

******************************************************************************** **********
ERROR occured!!

Could not get I2C GPIO device
******************************************************************************** **********

******************************************************************************** **********
ERROR occured!!

You might try to install the package again.
******************************************************************************** **********

dpkg: Fehler beim Bearbeiten des Paketes moitessier (–configure):
»installiertes moitessier-Skript des Paketes post-installation«-Unterprozess ga b den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
moitessier
E: Sub-process /usr/bin/dpkg returned an error code (1)

Grüße Nils

Answered question

7 Answers

Hallo Tim,

Ah okey. Jetzt wo ich es weiß verstehe ich es auch. Dann werde ich mal suchen müssen wie ich das umgehe. Parallel Betrieb soll laut Rooco möglich sein.

Nils

Answered question
You are viewing 1 out of 7 answers, click here to view all answers.
Write your answer.