Raspbery with Strompi stops working after X minutes

572 views
0 Comments

Hello,
I’ve connected the V3 StromPi on a Raspberry 3 and I’m using a 12Volt power supply. The power supply is originating from a car battery (but this time inside a boot), from the battery I’m using a 12V DC DC converter. The output of this converter (12V) is connected to the StomPi.
The problem is that when I boot up the Raspberry everything looks fine, the Raspberry boots perfectly and I can use the mouse, start an application etc. Unfortunately after 2 to 3 mins (roughly) the Raspberry suddenly stops completely. Nothing is working anymore. The blue HDMI led is switched off and the monitor has a black screen.
Any idea what is happening? Can the StromPi handle 12V as input? Will the Raspberry be powered with a good stable supply from the StromPi? How can I debug/analyse this problem?
Please help as I don’t know how to address/analyse this problem?
Thanks. Rene.

Answered question

7 Answers

Hi Rene,
Glad to see it’s working now. Have fun with the StromPi 3. If you have any further questions, don’t hesitate to contact us.
Best regards
Nils (Joy-IT)

Answered question
Rene (anonymous) 0 Comments

After the update of the firmware, reboot of the Raspberry and a walk through over the configuration I managed to get it working. I’ve connected a 12V power supply to the Wide Range input and the Raspberry keeps working (no shutdown). The StromPi3_Status python script is now also working, see output below.
pi@openplotter:~ $ sudo python StromPi3_Status.py
———————————
StromPi-Status:
———————————
Time: 00:02:32
Date: Tuesday 01.05.18
StromPi-Mode: Wide -> mUSB
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01:01
WakeUp-Alarm: Monday
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Raspberry Pi Shutdown: Disabled
Shutdown-Timer: 10 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Disabled
Interval-Alarm: Disabled
Interval-On-Time: 00 minutes
Interval-Off-Time: 00 minutes
Battery-Level Shutdown: Disabled
Firmware Version: v1.5
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: 12.158V
LifePo4-Batteryvoltage: not connected
microUSB-Inputvoltage: not connected
Output-Voltage: 5.119V
pi@openplotter:~ $

Answered question
Rene (anonymous) 0 Comments

This error message when executing the StromPi3_Status python script even occurs when I’ve upgraded to the V1.5 version. See status screen below from the serial console window:

—————————–
Welcome to the StromPi 3 Console
——————————
Type help to view a list of available commands.
[When you press ENTER the previous command would be executed again]
>show-status
Time: 00:01:58
Date: Tuesday 01.05.2018
StromPi-Mode: mUSB -> Wide
WakeUp-Alarm: D Time-Alarm
A00arm-Weekday: Monday
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Interval-Alarm: Disabled
Interval-Alarm-OnTime: 0 mi Interv: 0 minutes
Raspberry Pi Shutdown: Disabled
Shutdown-Timer: 10 seconds
Powerfail Warning: Enabled
Serial-Less Mabled
Battery-Level Shutdown: Disabled
FirmwareVersion: v1.5
>

Answered question
Anonymous 0 Comments

When I try to execute the StromPi3_Status script I get the following error message, what is wrong:

pi@openplotter:~ $ sudo python ./StromPi3_Status.py
Traceback (most recent call last):
File „./StromPi3_Status.py“, line 112, in <module>
sp3_ADC_Wide = float(serial_port.readline(9999))/1000;
ValueError: could not convert string to float:

Answered question

Hi Rene,
Your power supply setup should be within the specifications of the StromPi 3. So I don’t expect problems from this. We don’t need the image here. I just asked to be sure that the image isn’t causing this behavior. I’m going to wait for your results of the status script.
Best regards
Nils (Joy-IT)

Answered question
Write your answer.