Problems with Strom Pi v3 console

195 views
0 Comments

I’m having problems with the Strom Pi v3 console. After having installed minicom and starting it with „sudo minicom –D /dev/serial0 –b 38400“ command, it seems it doesn’t register my keystrokes. I mean literally, as I read that part on manual that they wouldn’t show on the console window, but as I type „startstrompiconsole“ + enter, nothing happens. I also tried that abbreviation and even copypasting „startstrompiconsole“ into the terminal just to make sure. I don’t think I can get past this phase or troubleshoot this on my own. What should I do?

I should probably also mention, I’m using Raspberry Pi 3 B with this and have lastest Raspbian on it, if it helps.

Answered question

7 Answers

Hi Northlander,

But there is a good message. The communication between your Raspberry Pi and your StromPi 3 seems already to work. If you have a look at the message with 1. on top of the box. This is a message from the StromPi console. If you see this message and type „help“ – depending on your StromPi firmware version – something like this should show up:

I hope I’ve been able to help you.

Best regards
Nils (Joy-IT)

Answered question
Northlander (anonymous) 0 Comments

Damn it, sorry for the spam. I got an update on my issue, in form of this picture:

I added some translations from my OS language. As the last resort I tried reinstalling minicom one more time, but nothing changed.

Answered question
Northlander again (anonymous) 0 Comments

Forgot to add, I changed manually that dev/tty8 into dev/serial0, speed was correct already. Saved, double-checked that the new settings were there. Still, nothing happens after I start minicom and type startstrompiconsole or sspc

Answered question
Northlander (anonymous) 0 Comments

Yes, I added
dtoverlay=pi3-miniuart-bt
enable_uart=1
core_freq=250
lines to the boot/config.txt. Double-checked for typos just now.
I followed this guide pretty much to the letter, but the problem persists.

Answered question

Hi Northlander,
thank you for the hint. We are going to correct this with the next release of the manual. Did you make the changes in /boot/config.txt? If yes, please try the steps from page 47 of this manual.

Best regards
Nils (Joy-IT)

Answered question
Write your answer.