Problems with Strom Pi v3 console

2.28K views
0 Comments

I’m having problems with the Strom Pi v3 console. After having installed minicom and starting it with „sudo minicom –D /dev/serial0 –b 38400“ command, it seems it doesn’t register my keystrokes. I mean literally, as I read that part on manual that they wouldn’t show on the console window, but as I type „startstrompiconsole“ + enter, nothing happens. I also tried that abbreviation and even copypasting „startstrompiconsole“ into the terminal just to make sure. I don’t think I can get past this phase or troubleshoot this on my own. What should I do?

I should probably also mention, I’m using Raspberry Pi 3 B with this and have lastest Raspbian on it, if it helps.

Answered question

13 Answers

Hi Pawmac,
is it possible, that your StromPi is still in flash mode? Please check the position of the flash jumper.
Do you have access to the console via minicom?
Have you successfully performed a firmware update?
Which firmware version do you use?
Best regards
Nils (Joy-IT)

Edited answer

I can not open StromPi console via minicom.

Answered question

Good morning. Can you hepl me with the problem above. I have tried everything what is described and nothing helped. I can log in to StromPi console using minicom. Any help Is welcome. Thank you in advance and regards.

Answered question
Northlander (anonymous) 0 Comments

I thought I had that disabled but apparently it was not. Disabled and rebooted, now the console seems to work as it should. Thank you! 🙂

Answered question
CDS (anonymous) 0 Comments

Are you shure you disabled the serial console access?
From the text-fragments it looks like getty is interfering with your serial communication …

Answered question
Write your answer.