Probleme mit Akku

1.31K views
0 Comments

Ich habe eine Raspberry Pi 3 mit StromPi 3 und AkkuHAT im Einsatz. Grundsätzlich funktioniert alles.
Momentan ist die primäre Quelle der USB Port und Failover der Akku (mit CAP ON)
Shutdown timer ist zu Testzwecken deaktiviert
Firmware 1.41
Wenn der USB Port abgesteckt wird (bei voll geladenem Akku) schaltet der StromPI laut LEDs auf den Akku um und läuft ca 1 Minute weiter. Nach der Minute blinkt das Ladeled am Akku kurz auf und der Raspberry ist plötzlich stromlos. Wärend dieser Minute habe ich mittes StromPi3_Status.py den Strom und Ladezustand des Akkus kontrolliert, dieser hat sich aber nicht nennenswert verändert.
Woran kann dies liegen und wie kann dies analysiert werden?
Danke

Answered question

10 Answers

Guten Tag Isabelle,
die show-status Werte sehen erst mal in Ordnung aus. Funktioniert der StromPi3 ohne BatteryHAT denn einwandfrei (mUSB und WIDE)?
Anhand Ihrer Fehlerbeschreibung vermute ich, dass es sich um eine defekte Akkuzelle auf dem BatteryHAT handelt. Sie können das aber selbst relativ gut testen, in dem Sie den Akku vollständig laden, dann mUSB trennen und während der BatteryHAT das System betreibt in minicom mit dem Befehl „adc-output“ die „LifePo4-Batteryvoltage“ beobachten. Dazu müssen Sie nur in regelmäßigen Abständen (in Ihrem Fall würde ich 5-10s empfehlen) „adc-output“ ausführen und schauen, wie sich die Spannung verhält. In 60 Sekunden ohne zusätzliche Last (z. B. zusätzliche USB Geräte) dürfte sich der „LifePo4-Batteryvoltage“ Wert kaum verändern. Sollten Sie aber feststellen, dass die Spannung Ihrer Zelle um z. B. 0,3 V fällt, handelt es sich mit großer Wahrscheinlichkeit um einen defekten BatteryHAT.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
You are viewing 1 out of 10 answers, click here to view all answers.
Write your answer.