No Serial console with fw v1.4

104 views
0 Comments

Hi,
after flashing Strompi to fw v1.4 the serial console doesn’t respond anymore. What can I do?

Answered question

3 Answers

Lorenz (anonymous) 0 Comments

Removing the Jumper for the Caps was the solution.

Answered question
Jarek (Joy-IT) (anonymous) 0 Comments

Hi,
@Lorenz
After a successful flash procedure the StromPi3 should start, when it is powered down and the Jumper for the Flashmode is changed to its off Position. Maybe there was a little bit charge left in the capacitors of the StromPi3 Ouput Caps and the StromPi3 didn’t managed to restart probably – please make sure that after a Firmware Flash no LEDs of the StromPi3 are lit up; as for this you can also disconnect the Jumper of the Caps, to be sure that there isn’t any voltage left.
Otherwise you can also try to reflash the v1.4 firmware (or revert back to an older firmware through the same flash procedure) if there was maybe be an issue in the flash procedure.
@Anonymous
Maybe the same Issue like it was pointed out by Lorenz has appeared in you case – I’d also try to reflash the StromPi3.
The Flashmode is a failsafe mode of the MCU which is integrated into the StromPi3, so it should work without restriction of previous firmware flashes.
Best Regards,
Jarek

Answered question
Anonymous 0 Comments

Exact same problem here.
succeed once and after the second try it won’t response after the
sudo screen /dev/serial0 38400
Very buggy software.

Answered question
Write your answer.