Konfiguration von PowerOff-Alarm und BatLevel-Poweroff

223 views
0 Comments

Hallo,
ich möchte mit dem StromPi-3 folgendes realisieren:
Primäre-Stromversorgung: mUSB 5V
Sekundäre-Stromversorgung: LiFePO-Batterie
Wenn die primäre Stromvesorgung ausfällt dann soll der RaspberryPI noch über die Batterie für 10 Sekunden weiter betrieben werden. Wenn die primäre Spannung in dieser Zeit nicht wiederkehrt soll er runtergefahren und abgeschaltet werden. Nach wiederkehr der primären Stromversorgung soll wieder automatisch eingeschaltet werden.
Aktuell funktioniert zwar das automatische abschalten, jedoch fährt der Raspberry nicht mehr hoch wenn die 5V mUSB erst nach einer längeren Zeit (z.B. 24h) wieder zugeschaltet werden. Der StromPI lässt sich dann nur durch entfernen der Batterie wieder dazu bewegen einen der Strompfade zu aktivieren.
Ist dieses Szenario möglich und wie müsste der StromPI 3 dazu konfiguriert werden?
Vielen Dank!

Answered question

3 Answers

Jarek (Joy-IT) (anonymous) 0 Comments

Hallo Mathias,
laut deiner geposteten Konfiguration ist der PowerOff-Alarm aktiviert, sodass der StromPi3 in dem Falle intern abschaltet und erst durch den WakeUp aufzuwachen wäre – ergibt sich die aufgezeigte Problematik auch, wenn der Poweroff-Alarm deaktiviert ist?
Gruß, Jarek

Answered question
Mathias (anonymous) 0 Comments

Hallo Nils,
aktuell habe ich folgende Konfiguration eingestellt.
Sobald die mUSB Spannung ausfällt übernimmt die Batterie die Stromversorgung (Wechsel rote LED auf grüne LED).
Der RaspberryPi fährt über das serialShutdown-Script runter und nach 30 Sekunden wird auch die Batteriespannung abgeschaltet. (grüne LED am StromPi  geht aus) Wenn jetzt die mUSB Spannung nach kurzer Zeit (1-2 Stunden) wiederkehrt, dann fährt der Raspberry auch korrekt wieder hoch.
Soweit alles OK.
Wenn aber erst nach längerer Zeit (z.B. nach einem Wochenende) die mUSB Spannung wieder eingeschaltet wird, dann bleiben alle LED’s am StromPi aus und der Raspberry bekommt auch keine Spannung. Nur ein abtrennen und aufstecken der Batterie hilft dann.

########################
pi@xxxxxx:~ $ ./StromPi3_Status.py
———————————
StromPi-Status:
———————————
Time: 00:16:54
Date: Tuesday 01.05.18
StromPi-Mode: mUSB -> Battery
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01:01
WakeUp-Alarm: Monday
PowerOff-Alarm: Enabled
PowerOff-Alarm-Time: 00:00
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 30 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Disabled
Battery-Level Shutdown: Disabled
Firmware Version: v1.41
———————————
Voltage-Levels:
———————————
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 3.301V [50%] [charging]
microUSB-Inputvoltage: 5.006V
Output-Voltage: 4.974V
pi@xxxxxx:~ $
########################

Answered question

Guten Morgen Mahtias,
dieses Szenario ist möglich und sollte so eigtl. auch konfigurierbar sein. Könnten Sie uns bitte um die Fehlersuche zu erleichtern die Konfiguration ihres StromPis posten? Nutzen Sie dazu bitte das  StromPi3-Status-Script.
Mit freundlichen Grüßen
Nils

Answered question
Write your answer.