Intervall Modus in Firmware 1.6 RC1 mit Battery HAT Problem

55 views
0 Comments

Hallo liebes Joy-IT Team
Ich versuche den StromPi v3 mit dem Battery HAT mit der neuesten Firmware 1.6 RC1 im Intervall Modus zu betreiben.
Mal ganz davon abgesehen dass im strompi_config.py Script ab Zeile 490 die Variable falsch benannt wurde zum Aktivieren des Intervall Modus, funktioniert dieser nämlich nicht.
Diese heißt nämlich nicht „intervalEnable“ sondern „sp3_intervalAlarm“. Hier der ausgebesserte Quellcode:

print(‚\n———————————————-‚)
print(‚ Interval-Alarm Configuration‘)
print(‚———————————————–‚)
alarmconfig = input(‚Do you want to change the Interval-Alarm-Configuration? (Y) Yes | (N) No:‘)
while not (alarmconfig == ‚Y‘ or alarmconfig == ‚N‘):
alarmconfig = input(‚Failed! Value not in Range – Please try again\nDo you want to change the Alarm-Configuration? (Y) Yes | (N) No: ‚)
if alarmconfig == ‚Y‘:
#poweroff-enable & poweroff-set-time
print(‚\n————————————–‚)
print(‚\nEnabling or disabling the Interval-Alarm (0 = disable, 1 = enable)\n‘)
sp3_intervalAlarm = input(‚Interval-Alarm status (0 – 1): ‚)
while int(
) < 0 or int(sp3_intervalAlarm) > 1:
sp3_intervalAlarm = input(‚Failed! Value not in Range – Please try again\nInterval-Alarm status (0 – 1): ‚)
if int(sp3_intervalAlarm) == 1:
print(‚\n————————————–‚)
print(‚\nSetting Interval-Time Settings\n‘)
sp3_intervalAlarmOnTime = input(‚Interval On-Time in minutes (1-65535): ‚)
while int(sp3_intervalAlarmOnTime) < 1 or int(sp3_intervalAlarmOnTime) > 65535:
sp3_intervalAlarmOnTime = input(‚Failed! Value not in Range – Please try again\nInterval On-Time in minutes (1-65535): ‚)
sp3_intervalAlarmOffTime = input(‚Interval Off-Time in minutes (1-65535): ‚)
while int(sp3_intervalAlarmOffTime) < 0 or int(sp3_intervalAlarmOffTime) > 65535:
sp3_intervalAlarmOffTime = input(‚Failed! Value not in Range – Please try again\nInterval Off-Time in minutes (1-65535): ‚)

Als Modus für die Energieversorgung ist Modus 3 eingestellt (mUSB -> Battery), und der Intervall Modus funktioniert genau solange bis ich das mUSB Kabel abziehe und der rPI mit dem Battery HAT läuft. Dieser führt den Intervall nämlich genau 1 mal aus und fährt den rPI daraufhin komplett hinunter.
Der automatische Shutdown ist allerdings deaktiviert beim Verlust der Primärspannungsquelle weswegen es hier ziemlich sicher einen Bug gibt.
Stecke ich die Primärspannungsquelle wieder an, so macht der StromPi mit dem Intervall ständig weiter.
Bitte um Hilfe
lg
hansman

Answered question

3 Answers

Guten Tag Hansman,
leider haben wir es vor dem Wochenende nicht mehr geschafft eine Lösung zur Verfügung zu stellen. Wir bitten um Entschuldigung.
Ich wünsche Ihnen schöne Ostern.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
hansman (anonymous) 0 Comments

Schönen guten Morgen

Vielen Dank 🙂

lg hansman

Answered question

Guten Morgen Hansman,
wir danken Ihnen für die ausführliche Beschreibung des Problems und werden den Fehler heute genauer untersuchen. Sobald wir Neuigkeiten haben, werden wir Sie hier informieren.
Mit freundlichen Grüßen
Nils (Joy-IT)

Answered question
Write your answer.