how to restart raspberry when the power is back

312 views

Hello , i am using strompi 3 with latest framework on raspberry 4 with two sources of alimentation :

1 : mUSB

2 : Strompi V3 battery HAT joy it

i followed the tutorial for the installation and configuration but there is still one thing i don’t understand and can’t impliment ; i am now able to swich to secondary source aka battery and shutoff raspberry after 60 seconds BUT it dosnt restart when the power is back on ..

what am i doing wrong ? what mode should i choose ? serial ou serialess ?

thank you in advance 🙂

Answered question

4 Answers

Hi,

If only your Raspberry Pi has been shut down, and your StromPi is still on when the primary power returns, your Raspberry Pi will not automatically restart.

i think that this problem is something that you should try to solve.

Can you update the software so that when StromPi shutdown timer expires, it will check, if primary power was returned.

If not, shut down StromPi, but if yes restart Raspberry.

Answered question

Hello Imed Salhi,

I could not find any mistakes in your configuration.

If only your Raspberry Pi has been shut down, and your StromPi is still on when the primary power returns, your Raspberry Pi will not automatically restart. When testing, please make sure that both the mUSB LED and the Battery LED are off before you restore the primary power supply.
If this does not solve the problem, please flash the latest firmware on the StromPi again. You can find it in our download area together with a manual. You can also try to use one of our prepared images for the test.

Best regards

Tim (Joy-it)

Answered question

>show-status

StromPi-Output: mUSB

StromPi-Mode: mUSB -> Battery

Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 60 seconds

Powerfail Warning: Enabled

Serial-Less Mode: Disabled

Power Save Mode: Disabled

Power-Off Mode: Disabled

Battery-Level Shutdown: Disabled

Powerfailure-Counter: 9

PowerOn-Button: Disabled
PowerOn-Button-Timer: 30 seconds

FirmwareVersion: v1.72

I enabled Raspi shutdown with a 60 seconds timer and chose musb ->battery mode

is there more configurations to set ? what am i doing wrong here ?

thank you for your help

Answered question

Can you give the status information? In the minicom console, type „sspc“ followed by „show-status“.

Answered question
Write your answer.