Frage zu BatteryHAT

122 views
0 Comments

Habe einen Strompi3 mit BatteryHAT mit folgendem Status:
Time: 02:17:10
Date: Tuesday 03.01.2019
StromPi-Mode: mUSB -> Battery
WakeUp-Alarm: Disabled
Alarm-Mode: Time-Alarm
Alarm-Time: 00:00
Alarm-Date: 01.01
Alarm-Weekday: Monday
PowerOff-Alarm: Disabled
PowerOff-Alarm-Time: 00:00
Raspberry Pi Shutdown: Enabled
Shutdown-Timer: 120 seconds
Powerfail Warning: Enabled
Serial-Less Mode: Disabled
Battery-Level Shutdown: Disabled
FirmwareVersion: v1.41

Allerdings dürfte der BatteryHAT nicht richtig laden…erstens leuchtet keine Status LED und zweitens pendelt der Charging-Status immer zwischen 0.565 V und 0.571 V.
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 0.571 V [charging]
microUSB-Inputvoltage: 4.959 V
Output-Voltage: 0.124 V
****************************
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 0.565 V [charging]
microUSB-Inputvoltage: 4.959 V
Output-Voltage: 0.121 V
****************************
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: 0.571 V [charging]
microUSB-Inputvoltage: 4.962 V
Output-Voltage: 0.124 V
****************************
Höher geht die Voltageanzeige des Akkus allerdings nicht….was ist hier Schuld? Ist eventuell der BatteryHAT defekt?
Was auch sehr seltsam ist, das System läuft nur wenn ich am Raspi mini USB und am Strompi 3 mini USB ein Netzteil anstecke – auch nicht normal oder?
Als Netzteil verwende ich das Standard Netzteil 5 Volt 2,5 Ampere.
Ich hoffe ihr könnt mir helfen.

Answered question

3 Answers

Guten Morgen Christian,
so wie es aussieht handelt es sich um einen defekt im Strompfad des ADC für die Akkuspannung. Leider kann ich per Ferndiagnose jetzt nicht sagen ob der defekt auf der Platine des StromPis, auf der Platine des Battery Hats ist oder erst durch den defekt des letzen StromPis verursacht wurde. Ich kann Ihnen anbieten beide Produkte an:
Simac Electronics Handel GmbH
z. Hd. Nils Hoever
Pascalstraße 8
47506 Neukirchen-Vluyn
zu senden und im Austausch zwei funktionierende Geräte zugesendet zu bekommen. Alternativ können Sie sich natürlich auch wieder an Ihren lokalen Händler wenden.
Mit freundlichen Grüßen
Nils

Answered question
Christian (anonymous) 0 Comments

Hallo Nils,
vielen Dank für die Antwort. Es war tatsächlich so das der Strompi 3 defekt war…heute 1:1 ausgetauscht bei dem Händler wo er gekauft wurde…soweit funktioniert es jetzt mal mit mUSB auf Strompi damit alles läuft….BatteryHAT LED leuchtet (also wird geladen)…..allerdings wird folgendes bei adc-output angezeigt:
****************************
Wide-Range-Inputvoltage: not connected
LifePo4-Batteryvoltage: not connected
microUSB-Inputvoltage: 5.113 V
Output-Voltage: 5.033 V
****************************
also die Battery wäre nicht angeschlossen? Was könnte hier noch das Problem sein?
mfg Christian

Answered question

Guten Morgen Christian,
dieses Verhalten scheint auf einen defekt am StromPi 3 oder am BatteryHat zurückzuführen zu sein. Eigtl. muss nur am „mUSB in“ des StromPis eine Spannungsversorgung angeschlossen werden. Wenn dieses der Fall ist sollte der BatteryHAT automatisch laden und dieses auch durch ein Leuchten der Charge LED verdeutlichen.
Um zu testen welches Gerät defekt ist ziehen Sie bitte den BatteryHat vom StromPi ab und schließen Sie nur am „mUSB in“ des StromPis eine Spannungsversorgung an. Sollte der Raspberry Pi dann normal hochfahren, ist dieses ein Hinweis auf einen defekten BatteryHat. Sollte der Raspberry Pi auch so nicht starten ist dieses ein Hinweis auf einen defekten StromPi.
Bitte wenden Sie sich für einen Austausch des defekten Geräts an service@joy-it.net oder telefonisch an +49 2845 9360 50. Sie können sich natürlich auch an den Händler wenden, bei dem Sie das Produkt gekauft haben.
Mit freundlichen Grüßen
Nils

Answered question
Write your answer.