Firmware Flash nicht möglich

5.93K views
0 Comments

Hallo Joy-IT-Team,
kann leider die neue Firmware am Strompi3 nicht flashen:
stm32flash /dev/serial0 -w v1.21/RB-StromPi3_Rev17102018_FixTimer_v1.21.binary -b 9600
bringt:
stm32flash 0.5
http://stm32flash.sourceforge.net/
Using Parser : Raw BINARY
Error probing interface „serial_posix“
Cannot handle device „/dev/serial0“
Failed to open port: /dev/serial0
Flash-Jumper ist auf On gesetzt, Stromversorgung über zwei USB-Netzteile ist an beiden Boards. Was kann/muss ich tun?
Danke + Gruß
Klaus

Answered question

21 Answers

Jarek (Joy-it) (anonymous) 0 Comments

Hallo Klaus,
Super dass es geklappt hat mit dem neu aufgespielten Image – warum dass jedoch zur besagten Problematik geführt hatte, kann ich von hier aus nicht sagen. Danke für die Vorschläge – wir werden diese in der nächsten Firmware mit einfügen. Da jedoch in NRW bei uns heute Feiertag ist, wird erst anfang nächster Woche die neue Version erscheinen.
Mit freundlichen Grüßen,
Jarek

Answered question
Klaus (anonymous) 0 Comments

Rückmeldung zu „aber innerhalb des screen-Befehls kommt keine Reaktion auf startstrompiconsole. Woran könnte das liegen?“
Habe nun ein unverändertes Raspbian-Image zur Konfiguration genommen. Damit klappt alles auf Anhieb. Der Hinweis kam an anderer Stelle in den FAQs schon. Empfehlung sowohl für das Flashen als auch für die Konfiguration ist somit: bei problemem den Vorgang mit einem möglichst unveränderten OS-Image zu machen. Ich habe noch nicht raus gefunden, warum der screen-Befehl in meinem normalen Image zickt. Habe einen USB-Stromleser dran, der als Protokoll auch Seriell verwendet. Hätte eigentlich vermutet, dass die Geräte und Konfigurationen sich nicht in die Quere kommen. aber für mich ist die Lösung mit einem rohen Image ok und Thema somit gelöst.
Gruß
Klaus

Answered question
Klaus (anonymous) 0 Comments

Hallo Jarek,
klasse wäre es, wenn nicht nur die Firmware-Version, sondern alle Werte mit show-status angezeigt würden, so dass man einen kompletten Überblick über alle eingestellten Werte bekommt. Bislang ist man teilweise im Blindflug unterwegs.
Und wenn dann noch alle Befehle über die serielle Schnittstelle nach aussen zugänglich gemacht würden, dann wäre es perfekt, um eigene Routinen in Skripten realisieren zu können (Reaktionen auf bestimmte Spannungen, …). Das würde sicher auch das eine oder andere Skript aus der Community für alle zurückspielen.
Noch eine Frage zum Abschluss: Heute habe ich den Akku bekommen und aufgesteckt. Wollte noch das Umschalten von Wide auf battery machen, aber innerhalb des screen-Befehls kommt keine Reaktion auf startstrompiconsole. Woran könnte das liegen?
Viele Grüße
Klaus

Answered question
Jarek (Joy-IT) (anonymous) 0 Comments

@Klaus
Wir freuen uns, dass das Firmware-Update nun geklappt hat – und vielen Dank für das beschreiben der Problemlösung hier im Forum und den Vorschlag mit der Firmware-Version – diese Funktion werden wir in der kommenden Firmware-Version integrieren.
@LanOpa
Ja, das stimmt – der Hinweis für die benötigte Konfiguration ist in der Firmware-Updateanleitung vielleicht etwas unklar geraten – wir werden hier die benötigen Schritte nochmal dort auflisten.
@Michael
Der etwas lange Befehl wurde gewählt um nicht mit anderer UART Kommunikation evenuell zu kollidieren, außerdem sollte es ein Befehl werden der weniger kryptisch im Kopf bleibt, sodass man nicht in der Anleitung nachschlagen müsse.
Das mit der Befehlsliste werden wir noch tunen – bis dahin werden wir eine komplette Befehlsliste unter unserem Github für die OpenSource-Firmware hochladen.
Wegen dem WakeUp-Befehl: Welche WakeUp Alarm Konfiguration ist den eingestellt? Und wie wird der StromPi3 bzw. der Raspberry Pi in den Standby Zustand heruntergefahren? Für die WakeUP Automatik muss neben dem Raspberry Pi auch der StromPi3 in den StandBy geschickt werden.
@Peter
Thank you for the tip with sudo – we will include it into our manual.

Answered question
Peter (anonymous) 0 Comments

Entschuldigung für die deutsche Übersetzung.
Sie müssen root sein oder sudo verwenden.
Ich musste die Strompi wieder auf Werkseinstellungen zurücksetzen. Ich vermute, der srompi-mode-Parameter zurück zum Original war die Lösung.

============
Sorry about the german translation.
You need to be root or use sudo.
I did need to put the strompi back in factory defaults. I suspect the srompi-mode parameter back to original was the solution.

Answered question
Write your answer.